Return-Path: X-Original-To: apmail-hbase-issues-archive@www.apache.org Delivered-To: apmail-hbase-issues-archive@www.apache.org Received: from mail.apache.org (hermes.apache.org [140.211.11.3]) by minotaur.apache.org (Postfix) with SMTP id 1C11C18C5C for ; Wed, 30 Dec 2015 23:04:50 +0000 (UTC) Received: (qmail 97208 invoked by uid 500); 30 Dec 2015 23:04:49 -0000 Delivered-To: apmail-hbase-issues-archive@hbase.apache.org Received: (qmail 97133 invoked by uid 500); 30 Dec 2015 23:04:49 -0000 Mailing-List: contact issues-help@hbase.apache.org; run by ezmlm Precedence: bulk List-Help: List-Unsubscribe: List-Post: List-Id: Delivered-To: mailing list issues@hbase.apache.org Received: (qmail 96963 invoked by uid 99); 30 Dec 2015 23:04:49 -0000 Received: from arcas.apache.org (HELO arcas) (140.211.11.28) by apache.org (qpsmtpd/0.29) with ESMTP; Wed, 30 Dec 2015 23:04:49 +0000 Received: from arcas.apache.org (localhost [127.0.0.1]) by arcas (Postfix) with ESMTP id 9F22C2C1F60 for ; Wed, 30 Dec 2015 23:04:49 +0000 (UTC) Date: Wed, 30 Dec 2015 23:04:49 +0000 (UTC) From: "Jonathan Hsieh (JIRA)" To: issues@hbase.apache.org Message-ID: In-Reply-To: References: Subject: [jira] [Updated] (HBASE-15061) Refactor StoreFileScanner creation to builder pattern MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-JIRA-FingerPrint: 30527f35849b9dde25b450d4833f0394 [ https://issues.apache.org/jira/browse/HBASE-15061?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Jonathan Hsieh updated HBASE-15061: ----------------------------------- Attachment: hbase-15061.v2.patch v1 forgot to copy the readpt. v2 fixes this. > Refactor StoreFileScanner creation to builder pattern > ----------------------------------------------------- > > Key: HBASE-15061 > URL: https://issues.apache.org/jira/browse/HBASE-15061 > Project: HBase > Issue Type: Improvement > Affects Versions: 2.0.0 > Reporter: Jonathan Hsieh > Assignee: Jonathan Hsieh > Fix For: 2.0.0 > > Attachments: hbase-15061.patch, hbase-15061.v2.patch > > > There are several falvors of calls that creates a list of StoreFileScanners, and new feature have been added to this recently. This patch converts the somewhat difficult to read (need to go to javadoc) call: > {code} > // which args are the most relevant to this? > - List sfScanners = StoreFileScanner.getScannersForStoreFiles(sfs, > - cacheMobBlocks, true, false, false, readPt); > {code} > into one that is more literate: > {code} > // ah, very clearly we are using defaults except for the caching settings > + List sfScanners = new StoreFileScanner.ListBuilder(sfs, readPt) > + .withCacheBlocks(cacheMobBlocks).build(); > {code} -- This message was sent by Atlassian JIRA (v6.3.4#6332)