hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-14964) Backport HBASE-14901 to brach-1 - There is duplicated code to create/manage encryption keys
Date Thu, 17 Dec 2015 20:10:47 GMT

    [ https://issues.apache.org/jira/browse/HBASE-14964?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15062705#comment-15062705
] 

Hadoop QA commented on HBASE-14964:
-----------------------------------

{color:green}+1 overall{color}.  

Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/16907//testReport/
Release Findbugs (version 2.0.3) 	warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/16907//artifact/patchprocess/newFindbugsWarnings.html
Checkstyle Errors: https://builds.apache.org/job/PreCommit-HBASE-Build/16907//artifact/patchprocess/checkstyle-aggregate.html

  Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/16907//console

This message is automatically generated.

> Backport HBASE-14901 to brach-1 - There is duplicated code to create/manage encryption
keys
> -------------------------------------------------------------------------------------------
>
>                 Key: HBASE-14964
>                 URL: https://issues.apache.org/jira/browse/HBASE-14964
>             Project: HBase
>          Issue Type: Improvement
>          Components: encryption
>            Reporter: Nate Edel
>            Assignee: Nate Edel
>            Priority: Minor
>             Fix For: 1.3.0
>
>         Attachments: HBASE-14964-branch-1.1.patch, HBASE-14964.1.branch-1.patch, HBASE-14964.patch
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> There is duplicated code from MobUtils.createEncryptionContext in HStore, and there is
a subset of that code in HFileReaderImpl.
> Refactored key selection 
> Moved both to EncryptionUtil.java
> Can't figure out how to write a unit test for this, but there's no new code just refactoring.
> A lot of the Mob stuff hasn't been backported, so this is a very small patch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message