hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Romil Choksi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-14804) HBase shell's create table command ignores 'NORMALIZATION_ENABLED' attribute
Date Fri, 13 Nov 2015 01:22:11 GMT
Romil Choksi created HBASE-14804:
------------------------------------

             Summary: HBase shell's create table command ignores 'NORMALIZATION_ENABLED' attribute
                 Key: HBASE-14804
                 URL: https://issues.apache.org/jira/browse/HBASE-14804
             Project: HBase
          Issue Type: Bug
          Components: shell
    Affects Versions: 1.1.2
            Reporter: Romil Choksi


I am trying to create a new table and set the NORMALIZATION_ENABLED as true, but seems like
the argument NORMALIZATION_ENABLED is being ignored. And the attribute NORMALIZATION_ENABLED
is not displayed on doing a desc command on that table
hbase(main):020:0> create 'test-table-4', 'cf', {NORMALIZATION_ENABLED => 'true'}
An argument ignored (unknown or overridden): NORMALIZATION_ENABLED
0 row(s) in 4.2670 seconds

=> Hbase::Table - test-table-4
hbase(main):021:0> desc 'test-table-4'
Table test-table-4 is ENABLED                                                            
                                                                                         
                        
test-table-4                                                                             
                                                                                         
                        
COLUMN FAMILIES DESCRIPTION                                                              
                                                                                         
                        
{NAME => 'cf', BLOOMFILTER => 'ROW', VERSIONS => '1', IN_MEMORY => 'false', KEEP_DELETED_CELLS
=> 'FALSE', DATA_BLOCK_ENCODING => 'NONE', TTL => 'FOREVER', COMPRESSION => 'NONE',
MIN_VERSIONS => '0', BLOC
KCACHE => 'true', BLOCKSIZE => '65536', REPLICATION_SCOPE => '0'}               
                                                                                         
                                 
1 row(s) in 0.0430 seconds
However, on doing an alter command on that table we can set the NORMALIZATION_ENABLED attribute
for that table
hbase(main):022:0> alter 'test-table-4', {NORMALIZATION_ENABLED => 'true'}
Unknown argument ignored: NORMALIZATION_ENABLED
Updating all regions with the new schema...
1/1 regions updated.
Done.
0 row(s) in 2.3640 seconds

hbase(main):023:0> desc 'test-table-4'
Table test-table-4 is ENABLED                                                            
                                                                                         
                        
test-table-4, {TABLE_ATTRIBUTES => {NORMALIZATION_ENABLED => 'true'}               
                                                                                         
                              
COLUMN FAMILIES DESCRIPTION                                                              
                                                                                         
                        
{NAME => 'cf', BLOOMFILTER => 'ROW', VERSIONS => '1', IN_MEMORY => 'false', KEEP_DELETED_CELLS
=> 'FALSE', DATA_BLOCK_ENCODING => 'NONE', TTL => 'FOREVER', COMPRESSION => 'NONE',
MIN_VERSIONS => '0', BLOC
KCACHE => 'true', BLOCKSIZE => '65536', REPLICATION_SCOPE => '0'}               
                                                                                         
                                 
1 row(s) in 0.0190 seconds
I think it would be better to have a single step process to enable normalization while creating
the table itself, rather than a two step process to alter the table later on to enable normalization



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message