hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-14392) [tests] TestLogRollingNoCluster fails on master from time to time
Date Thu, 10 Sep 2015 06:46:45 GMT

    [ https://issues.apache.org/jira/browse/HBASE-14392?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14738275#comment-14738275
] 

Hadoop QA commented on HBASE-14392:
-----------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12755059/14392v2.txt
  against master branch at commit a11bb2a933ad799546e7179fdf6ce75e3e22d44b.
  ATTACHMENT ID: 12755059

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 3 new or modified
tests.

    {color:green}+1 hadoop versions{color}. The patch compiles with all supported hadoop versions
(2.4.0 2.4.1 2.5.0 2.5.1 2.5.2 2.6.0 2.7.0 2.7.1)

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 protoc{color}.  The applied patch does not increase the total number of
protoc compiler warnings.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 checkstyle{color}.  The applied patch does not increase the total number
of checkstyle errors

    {color:green}+1 findbugs{color}.  The patch does not introduce any  new Findbugs (version
2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 lineLengths{color}.  The patch does not introduce lines longer than 100

  {color:green}+1 site{color}.  The mvn post-site goal succeeds with this patch.

     {color:red}-1 core tests{color}.  The patch failed these unit tests:
                       org.apache.hadoop.hbase.master.TestDistributedLogSplitting

     {color:red}-1 core zombie tests{color}.  There are 5 zombie test(s): 	at org.apache.hadoop.hbase.replication.regionserver.TestReplicationWALReaderManager.test(TestReplicationWALReaderManager.java:181)
	at org.apache.hadoop.hbase.io.hfile.TestCacheOnWrite.testNotCachingDataBlocksDuringCompactionInternals(TestCacheOnWrite.java:484)
	at org.apache.hadoop.hbase.io.hfile.TestCacheOnWrite.testNotCachingDataBlocksDuringCompaction(TestCacheOnWrite.java:508)
	at org.apache.hadoop.hbase.TestAcidGuarantees.testMobScanAtomicity(TestAcidGuarantees.java:408)

Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/15519//testReport/
Release Findbugs (version 2.0.3) 	warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/15519//artifact/patchprocess/newFindbugsWarnings.html
Checkstyle Errors: https://builds.apache.org/job/PreCommit-HBASE-Build/15519//artifact/patchprocess/checkstyle-aggregate.html

  Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/15519//console

This message is automatically generated.

> [tests] TestLogRollingNoCluster fails on master from time to time
> -----------------------------------------------------------------
>
>                 Key: HBASE-14392
>                 URL: https://issues.apache.org/jira/browse/HBASE-14392
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>            Reporter: stack
>            Assignee: stack
>         Attachments: 14392.txt, 14392.txt, 14392v2.txt
>
>
> TestLogRollingNoCluster fails from time to time on a rig I have running here.
> Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support
was removed in 8.0
> Running org.apache.hadoop.hbase.regionserver.wal.TestLogRollingNoCluster
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 3.155 sec - in org.apache.hadoop.hbase.regionserver.wal.TestLogRollingNoCluster
> Results :
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0
> The test itself is a bit odd. We apparently have seen NPEs around close of a WAL while
trying to sync... which I suppose makes sense if two threads involved.
> Attached patch just fails the sync silently if stream is null... lets presume it a close.
Adds a sync on write of trailer too... 
> This patch seems to have gotten rid of the odd failure seen on a particular box here
if I keep cycling the test.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message