hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-14203) remove duplicate code getTableDescriptor in HTable
Date Tue, 11 Aug 2015 11:06:45 GMT

    [ https://issues.apache.org/jira/browse/HBASE-14203?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14681616#comment-14681616
] 

Enis Soztutar commented on HBASE-14203:
---------------------------------------

Creating an Admin is a costly operation. Maybe we can extract the method to be a static one.

{code}
+    HTableDescriptor htd = this.connection.getAdmin().getTableDescriptor(tableName);
{code}

> remove duplicate code getTableDescriptor in HTable
> --------------------------------------------------
>
>                 Key: HBASE-14203
>                 URL: https://issues.apache.org/jira/browse/HBASE-14203
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Heng Chen
>            Priority: Trivial
>         Attachments: HBASE-14203.patch
>
>
> As TODO in comment said, 
> {{HTable.getTableDescriptor}} is same as {{HAdmin.getTableDescriptor}}. remove the duplicate
code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message