hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabor Liptak (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13852) Replace master-slave terminology in book, site, and javadoc with a more modern vocabulary
Date Thu, 09 Jul 2015 01:07:04 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13852?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14619683#comment-14619683
] 

Gabor Liptak commented on HBASE-13852:
--------------------------------------

Based on a quick review, the master/slave terminology is exposed in interfaces (there is a
"master" command, there are environment variables like HBASE_SLAVE_SLEEP), in the API (stopMaster()),
file names, etc. How extensive incompatible changes are acceptable around this?

Also is coordinator/regionserver would be the preferred rename?

> Replace master-slave terminology in book, site, and javadoc with a more modern vocabulary
> -----------------------------------------------------------------------------------------
>
>                 Key: HBASE-13852
>                 URL: https://issues.apache.org/jira/browse/HBASE-13852
>             Project: HBase
>          Issue Type: Task
>          Components: documentation, site
>            Reporter: Andrew Purtell
>            Priority: Minor
>             Fix For: 2.0.0
>
>
> We should reconsider our use of historical master-slave terminology everywhere - book,
site, and javadoc - and replace it with a more modern vocabulary. There was a conversation
in the background at HBaseCon about this (I was involved in one on Twitter). Out of some of
the suggestions, I like "coordinator" as replacement for "master", and "worker" as one replacement
for "slave", with the other the more descriptive "regionserver" or "region server".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message