hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13107) Refactor MOB Snapshot logic to reduce code duplication.
Date Wed, 22 Jul 2015 22:49:20 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13107?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14637819#comment-14637819
] 

Hudson commented on HBASE-13107:
--------------------------------

FAILURE: Integrated in HBase-TRUNK #6672 (See [https://builds.apache.org/job/HBase-TRUNK/6672/])
HBASE-13107 Refactor MOB Snapshot logic to reduce code duplication (Jingcheng Du) (jmhsieh:
rev dae8f236dcb20ed6e411777f69c362aef72ec390)
* hbase-server/src/main/java/org/apache/hadoop/hbase/snapshot/SnapshotManifest.java
* hbase-server/src/main/java/org/apache/hadoop/hbase/snapshot/RestoreSnapshotHelper.java


> Refactor MOB Snapshot logic to reduce code duplication.
> -------------------------------------------------------
>
>                 Key: HBASE-13107
>                 URL: https://issues.apache.org/jira/browse/HBASE-13107
>             Project: HBase
>          Issue Type: Sub-task
>          Components: mob, snapshots
>    Affects Versions: hbase-11339
>            Reporter: Jonathan Hsieh
>            Assignee: Jingcheng Du
>             Fix For: hbase-11339
>
>         Attachments: HBASE-13107.diff
>
>
> The MOB Snapshot code contains a lot of code duplication with the normal snapshot code
path. We should do some refactoring to clean this up before merging.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message