hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop Sam John (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13871) Change RegionScannerImpl to deal with Cell instead of byte[], int, int
Date Wed, 10 Jun 2015 05:42:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13871?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14580057#comment-14580057
] 

Anoop Sam John commented on HBASE-13871:
----------------------------------------

bq.Do we have to have a class named FirstOnRowFakeCell at top level of our class hierarchy?
Is it only used in CellUtil? Could it be an inner class of it?
I will change it in next patch. BTW , we might add some more similar classes in future. This
is byte[] backed fake Cell impl and we will have a BB backed one also.  Also LastOnRowFakeCell
will come in..  JFYI.  I will keep this class(es) private audience only even if CellUtil is
public exposed.  Thanks Stack.

> Change RegionScannerImpl to deal with Cell instead of byte[], int, int
> ----------------------------------------------------------------------
>
>                 Key: HBASE-13871
>                 URL: https://issues.apache.org/jira/browse/HBASE-13871
>             Project: HBase
>          Issue Type: Sub-task
>          Components: regionserver, Scanners
>            Reporter: Anoop Sam John
>            Assignee: Anoop Sam John
>             Fix For: 2.0.0
>
>         Attachments: HBASE-13871.patch, HBASE-13871.patch
>
>
> This is also a sub item for splitting HBASE-13387 into smaller chunks.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message