hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13852) Replace master-slave terminology in book, site, and javadoc with a more modern vocabulary
Date Sun, 07 Jun 2015 00:43:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13852?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14576040#comment-14576040
] 

Andrew Purtell commented on HBASE-13852:
----------------------------------------

While some with think this is bikeshedding, let me just say I was surprised by the intensity
of the eye rolling from some quarters of the HBaseCon audience. 

> Replace master-slave terminology in book, site, and javadoc with a more modern vocabulary
> -----------------------------------------------------------------------------------------
>
>                 Key: HBASE-13852
>                 URL: https://issues.apache.org/jira/browse/HBASE-13852
>             Project: HBase
>          Issue Type: Task
>          Components: documentation, site
>            Reporter: Andrew Purtell
>            Priority: Minor
>             Fix For: 2.0.0
>
>
> We should reconsider our use of historical master-slave terminology everywhere - book,
site, and javadoc - and replace it with a more modern vocabulary. There was a conversation
in the background at HBaseCon about this (I was involved in one on Twitter). Out of some of
the suggestions, I like "coordinator" as replacement for "master", and "worker" as one replacement
for "slave", with the other the more descriptive "regionserver" or "region server".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message