hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srikanth Srungarapu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13755) Provide single super user check implementation
Date Tue, 09 Jun 2015 01:29:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13755?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14578162#comment-14578162
] 

Srikanth Srungarapu commented on HBASE-13755:
---------------------------------------------

Formally -1 on the patch in the current form.
- IMHO, {{SuperUsers}} is a misnomer. There are a couple of methods namely {{public static
String getGroupName(String aclKey)}} and {{public static boolean isGroupPrincipal(String name)}},
which don't have anything to do with superusers.
- May be you can add them to existing {{AuthUtil}} in hbase-common module.



> Provide single super user check implementation
> ----------------------------------------------
>
>                 Key: HBASE-13755
>                 URL: https://issues.apache.org/jira/browse/HBASE-13755
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Anoop Sam John
>            Assignee: Mikhail Antonov
>             Fix For: 2.0.0, 1.2.0
>
>         Attachments: HBASE-13755-v1.patch, HBASE-13755-v2.patch, HBASE-13755-v3.patch,
HBASE-13755-v3.patch, HBASE-13755-v3.patch, HBASE-13755-v3.patch, HBASE-13755-v3.patch
>
>
> Followup for HBASE-13375.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message