hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apekshit Sharma (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-13692) Use DataChecksum.Type instead of ChecksumType
Date Thu, 14 May 2015 22:39:00 GMT
Apekshit Sharma created HBASE-13692:
---------------------------------------

             Summary: Use DataChecksum.Type instead of ChecksumType
                 Key: HBASE-13692
                 URL: https://issues.apache.org/jira/browse/HBASE-13692
             Project: HBase
          Issue Type: Bug
            Reporter: Apekshit Sharma
            Priority: Minor


Earlier, ChecksumType handled initializing classes for checksumming HFile. In order to use
[Native Hadoop Library|http://hadoop.apache.org/docs/r2.4.1/hadoop-project-dist/hadoop-common/NativeLibraries.html],
we started using DataChecksum and ChecksumType is not really doing anything. It might be better
to use DataChecksum.Type everywhere.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message