hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashish Singhi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13658) Improve the test run time for TestAccessController* classes
Date Tue, 12 May 2015 08:49:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14539535#comment-14539535
] 

Ashish Singhi commented on HBASE-13658:
---------------------------------------

[~andrew.purtell@gmail.com]
bq. Not every unit creates users and adds grants, but some do. Add cleanup code for when that
is the case 
I did this in first patch but only table and users which are available at class level.
{code}
+    // Grant the revoked permission back to the user
+    grantOnTable(TEST_UTIL, USER_RO.getShortName(), TEST_TABLE, TEST_FAMILY, null,
+      Permission.Action.READ);
{code}
but not for method level user.
In v1 patch I have addressed this for method level users also. In test where we are creating
local test table and granting permission, I have not revoked the permission at the end as
we will be deleting the table by the end of the test, so IMO its not required.

I have reverted the changes from TestAccessController2 as in that class we have 4 tests and
all test adds grants, so instead of adding cleanup code in all the test, I have let the tearDown
to do that.

[~srikanth235]
bq. Please rename setUp() and tearDown() methods 
Addressed.

Please review.
Thanks

> Improve the test run time for TestAccessController* classes
> -----------------------------------------------------------
>
>                 Key: HBASE-13658
>                 URL: https://issues.apache.org/jira/browse/HBASE-13658
>             Project: HBase
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Ashish Singhi
>            Assignee: Ashish Singhi
>         Attachments: 13658.patch, HBASE-13658-v1.patch, HBASE-13658.patch
>
>
> Improve the test run time for TestAccessController* classes



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message