hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop Sam John (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13645) Rename *column methods in MasterObserver to *columnFamily
Date Fri, 08 May 2015 07:27:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14534028#comment-14534028
] 

Anoop Sam John commented on HBASE-13645:
----------------------------------------

+1 for option#1.  We have done similar way in the past.

> Rename *column methods in MasterObserver to *columnFamily
> ---------------------------------------------------------
>
>                 Key: HBASE-13645
>                 URL: https://issues.apache.org/jira/browse/HBASE-13645
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Lars Francke
>            Assignee: Lars Francke
>            Priority: Minor
>
> This being an interface makes it a bit harder on implementors. It'd be easier with Java8
and default implementations.
> We could either
> # add new *columnFamily methods and deprecate the old ones or
> # rename the existing ones without doing a deprecation first.
> Implementors would need to change their code in each of those cases. But because we have
the {{BaseMasterObserver}} and {{BaseMasterAndRegionObserver}} it'd make things easier for
people using those classes if we go with option 1. So that's my preference.
> The plan would be to add these methods in 2.0.0 and remove the old ones in 3.0.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message