hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "zhangduo (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13637) branch-1.1 does not build against hadoop-2.2.
Date Thu, 07 May 2015 00:10:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13637?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14531741#comment-14531741
] 

zhangduo commented on HBASE-13637:
----------------------------------

{quote}
It seems that 2.2 does not contain mini KDC at all
{quote}

Yes, mini-kdc is first introduced in hadoop 2.3.
But as [~apurtell] said before, mini-kdc does not depends on any other hadoop modules.
See here
http://mvnrepository.com/artifact/org.apache.hadoop/hadoop-minikdc/2.7.0

So we could give mini-kdc a separated version instead of the common hadoop-two.version? I
can prepare a patch for it.

Thanks.

> branch-1.1 does not build against hadoop-2.2.
> ---------------------------------------------
>
>                 Key: HBASE-13637
>                 URL: https://issues.apache.org/jira/browse/HBASE-13637
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Nick Dimiduk
>             Fix For: 1.1.0
>
>
> From RC0 VOTE thread,
> {quote}
> The build is broken with Hadoop-2.2 because mini-kdc is not found:
> \[ERROR\] Failed to execute goal on project hbase-server: Could not resolve dependencies
for project org.apache.hbase:hbase-server:jar:1.1.0: Could not find artifact org.apache.hadoop:hadoop-minikdc:jar:2.2
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message