hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop Sam John (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13502) Deprecate/remove getRowComparator() in TableName
Date Tue, 21 Apr 2015 18:46:02 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14505495#comment-14505495
] 

Anoop Sam John commented on HBASE-13502:
----------------------------------------

bq.private KVComparator getRowComparator(TableName tableName) 
I believe you will change this type to CellComparator in HBASE-10800.

{quote}
I think it clearer if you write it as:
return TableName.META_TABLE_NAME.equals(tableName)? KeyValue.META_COMPARATOR: KeyValue.COMPARATOR;
{quote}
I also think we can do this way as Stack suggested.

+1. Can correct on commit.

> Deprecate/remove getRowComparator() in TableName
> ------------------------------------------------
>
>                 Key: HBASE-13502
>                 URL: https://issues.apache.org/jira/browse/HBASE-13502
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: ramkrishna.s.vasudevan
>            Assignee: ramkrishna.s.vasudevan
>             Fix For: 2.0.0
>
>         Attachments: HBASE-13502.patch, HBASE-13502_1.patch, HBASE-13502_2.patch, HBASE-13502_2.patch,
HBASE-13502_3.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message