hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matteo Bertozzi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13326) Disabled table can't be enabled after HBase is restarted
Date Wed, 25 Mar 2015 08:04:53 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13326?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14379461#comment-14379461
] 

Matteo Bertozzi commented on HBASE-13326:
-----------------------------------------

TestEnableTableHandler.testEnableTableWithNoRegionServers() is failing for this change
{code}
-    TEST_UTIL.startMiniCluster(1);
+    TEST_UTIL.startMiniCluster(1, 2);
{code}

> Disabled table can't be enabled after HBase is restarted
> --------------------------------------------------------
>
>                 Key: HBASE-13326
>                 URL: https://issues.apache.org/jira/browse/HBASE-13326
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 1.0.0, 1.1.0, 0.98.12
>            Reporter: Dima Spivak
>            Assignee: Andrey Stepachev
>            Priority: Blocker
>             Fix For: 1.0.1, 1.1.0, 0.98.12
>
>         Attachments: HBASE-13326-0.98.patch, HBASE-13326-branch-1.0.patch, HBASE-13326-branch-1.0.patch,
HBASE-13326-branch-1.patch
>
>
> The folks at Intel discovered a pretty nasty bug in 1.0 and 1.1 (but not master). Steps
to reproduce:
> 1. Create a table, any table.
> 2. Disable the table.
> 3. Restart HBase.
> 4. Try enabling the table.
> The table won't become enabled and the master web UI will indicate a never-ending region
in transition. Also worth noting is that [~mbertozzi] dug in and noted that this isn't happening
in the master branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message