hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Dimiduk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13319) Support 64-bits total row number in PerformanceEvaluation
Date Wed, 25 Mar 2015 00:47:53 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13319?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14379037#comment-14379037
] 

Nick Dimiduk commented on HBASE-13319:
--------------------------------------

nit: some places you've replaced a magic number with TASKS_PER_CLIENT. Should this be done
more uniformly?

{noformat}
-          next.startRow = (j * perClientRows) + (i * (perClientRows/10));
-          next.perClientRunRows = perClientRows / 10;
+          next.startRow = (j * perClientRows) + (i * (perClientRows/TASKS_PER_CLIENT));
+          next.perClientRunRows = perClientRows / TASKS_PER_CLIENT;
{noformat}

+1 otherwise.

> Support 64-bits total row number in PerformanceEvaluation
> ---------------------------------------------------------
>
>                 Key: HBASE-13319
>                 URL: https://issues.apache.org/jira/browse/HBASE-13319
>             Project: HBase
>          Issue Type: Improvement
>          Components: Performance
>            Reporter: Liu Shaohui
>            Assignee: Liu Shaohui
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: HBASE-13319-trunk-v1.diff
>
>
> Currently the total row number in PerformanceEvaluation is 32 bits. It's not enough when
testing a large hbase cluster using PerformanceEvaluation in mapreduce mode.
> Suggestions are welcomed~ Thanks



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message