hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bhupendra Kumar Jain (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-13049) wal_roll ruby command doesn't work.
Date Mon, 16 Feb 2015 13:29:12 GMT

     [ https://issues.apache.org/jira/browse/HBASE-13049?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bhupendra Kumar Jain updated HBASE-13049:
-----------------------------------------
    Status: Patch Available  (was: Open)

Patch attached. Please review. 

> wal_roll ruby command doesn't work. 
> ------------------------------------
>
>                 Key: HBASE-13049
>                 URL: https://issues.apache.org/jira/browse/HBASE-13049
>             Project: HBase
>          Issue Type: Bug
>          Components: shell
>            Reporter: Bhupendra Kumar Jain
>         Attachments: 0001-HBASE-13049-wal_roll-ruby-command-doesn-t-work.patch
>
>
> On execution of wal_roll command in shell, error message gets displayed as shown below
> hbase(main):005:0> wal_roll 'host-10-19-92-94,16201,1424081618286'
> *ERROR: cannot convert instance of class org.jruby.RubyString to class org.apache.hadoop.hbase.ServerName*
> its because Admin Java api expecting a ServerName object but script passes the ServerName
as string. 
> currently script is as below
> {code}
> @admin.rollWALWriter(server_name)
> {code}
> It should be like 
> {code}
> @admin.rollWALWriter(ServerName.valueOf(server_name))
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message