hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13028) Cleanup mapreduce API changes
Date Fri, 13 Feb 2015 20:19:11 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13028?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14320690#comment-14320690
] 

Sean Busbey commented on HBASE-13028:
-------------------------------------

I've had to breaking change an API that's new in 1.0. I could possible work around this in
1.1, but it would be ugly.

> Cleanup mapreduce API changes
> -----------------------------
>
>                 Key: HBASE-13028
>                 URL: https://issues.apache.org/jira/browse/HBASE-13028
>             Project: HBase
>          Issue Type: Bug
>          Components: mapreduce
>    Affects Versions: 1.0.0
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>            Priority: Blocker
>              Labels: api
>             Fix For: 1.0.0, 2.0.0
>
>
> The API changes made in HBASE-12798 need to be cleaned up so their common use makes more
sense.
> * initialize should take some kind of configuration object that can be used in setting
up a Connection (e.g. JobConf)
> * initialize should be called at the start of getSplits and getRecordReader rather than
across the class when a member is needed
> * the same changes should be present in the mapred package since it is not longer deprecated
> * examples should rely on idiomatic MapReduce (specifically they should not be relying
on JobConfigurable to get a JobConf instance)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message