hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-12920) hadoopqa should compile with different hadoop versions
Date Wed, 28 Jan 2015 23:51:36 GMT

     [ https://issues.apache.org/jira/browse/HBASE-12920?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Enis Soztutar updated HBASE-12920:
----------------------------------
    Assignee: Enis Soztutar
      Status: Patch Available  (was: Open)

> hadoopqa should compile with different hadoop versions 
> -------------------------------------------------------
>
>                 Key: HBASE-12920
>                 URL: https://issues.apache.org/jira/browse/HBASE-12920
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Enis Soztutar
>            Assignee: Enis Soztutar
>             Fix For: 2.0.0
>
>         Attachments: hbase-12920_v1.patch
>
>
> From time to time, we break compilation with hadoop-2.4 or other earlier versions, and
only realize that at the time of a release candidate. 
> We should fix hadoopqa to do the compilation for us. 
> What I have locally is something like this: 
> {code}
> HADOOP2_VERSIONS="2.2.0 2.3.0 2.4.0 2.5.0 2.6.0"
> function buildWithHadoop2 {
>   for HADOOP2_VERSION in $HADOOP2_VERSIONS ; do
>     echo ""
>     echo "##### BUILDING $ARTIFACT WITH HADOOP 2 VERSION $HADOOP2_VERSION #####"
>     echo ""
>     echo mvn clean install -DskipTests -Dhadoop-two.version=$HADOOP2_VERSION
>     mvn clean install -DskipTests -Dhadoop-two.version=$HADOOP2_VERSION
>   done
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message