hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "suraj misra (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11164) Document and test rolling updates from 0.98 -> 1.0
Date Thu, 29 Jan 2015 12:39:34 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11164?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14296778#comment-14296778
] 

suraj misra commented on HBASE-11164:
-------------------------------------

I am getting same error.
My environment had hbase 94.18. After that I  have installed hbase 98.9 version. It was working
fine for both the cases. but when I once again want to start 94.18 version. It gives me the
following error:

FATAL org.apache.hadoop.hbase.master.HMaster: Unhandled exception. Starting shutdown.
java.lang.NullPointerException
        at org.apache.hadoop.hbase.util.Bytes.toBytes(Bytes.java:441)
        at org.apache.hadoop.hbase.zookeeper.ClusterId.setClusterId(ClusterId.java:72)
        at org.apache.hadoop.hbase.master.HMaster.finishInitialization(HMaster.java:581)
        at org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:433)


> Document and test rolling updates from 0.98 -> 1.0
> --------------------------------------------------
>
>                 Key: HBASE-11164
>                 URL: https://issues.apache.org/jira/browse/HBASE-11164
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Enis Soztutar
>            Assignee: stack
>            Priority: Critical
>             Fix For: 0.99.2
>
>
> I think 1.0 should be rolling upgradable from 0.98 unless we break it intentionally for
a specific reason. Unless there is such an issue, lets document that 1.0 and 0.98 should be
rolling upgrade compatible. 
> We should also test this before the 0.99 release. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message