hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Solomon Duskis (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-12611) Create autoCommit() method and remove clearBufferOnFail
Date Fri, 05 Dec 2014 00:09:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-12611?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14234824#comment-14234824

Solomon Duskis commented on HBASE-12611:

stack asked about the is vs. get issue as well.  Since we used java.sql.Connection as a an
example for setAutoCommit(), I used java.sql.Connection's getAutoCommit() syntax as well.
 If you want me to change it to isAutoCommit(), I can do that.  See [~stack]'s comment above.

> Create autoCommit() method and remove clearBufferOnFail
> -------------------------------------------------------
>                 Key: HBASE-12611
>                 URL: https://issues.apache.org/jira/browse/HBASE-12611
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 2.0.0, 0.99.2
>            Reporter: Solomon Duskis
>            Assignee: Solomon Duskis
>             Fix For: 1.0.0
>         Attachments: HBASE-12611.patch
> There was quite a bit of good discussion on HBASE-12490 about this topic.  [~stack] and
[~ndimiduk] came to the conclusion that the flush method should be called autoCommit() similar
to the SQL APIs.   [~ndimiduk]  also suggested that clearBufferOnFail should be removed from

This message was sent by Atlassian JIRA

View raw message