hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicolas Liochon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-12611) Create autoCommit() method and remove clearBufferOnFail
Date Thu, 04 Dec 2014 09:23:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-12611?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14234055#comment-14234055

Nicolas Liochon commented on HBASE-12611:

bq.  stack and Nick Dimiduk came to the conclusion that the flush method should be called
autoCommit() similar to the SQL APIs.
Sorry for beeing late in the game. The meaning in SQL is slightly different. In jdbc, whatever
the value for autoCommit, the query will be sent to be server and executed. autocommit is
set to false if the client application wants to send multiple queries within a single transaction
(and then it will do a begin/commit explicitly). I haven't double checked if it's the standard
or an implementation detail (the docs are not very clear), but it's unlikely to change anyway:
there is another set of methods for batches in jdbc.
Our old autoFlush is different as it impacts the client behavior. I think we're creating a
confusion here. Moreover, if we add transactions between rows in the future, then may be we
will want to use autoCommit for what it really is. As I'm very late here I leave the decision
to you, but we should at least be clear in the javadoc imho.

bq. Do we also want to change the default with this patch?
I like the fact that HBase its secure by default and it would be very confusing for the users
as well imho.

-  public boolean isAutoFlush() {
-    return autoFlush;
+  public boolean getAutoCommit() {
+    return autoCommit;
If I'm not wrong we use 'is' for getters on boolean?

> Create autoCommit() method and remove clearBufferOnFail
> -------------------------------------------------------
>                 Key: HBASE-12611
>                 URL: https://issues.apache.org/jira/browse/HBASE-12611
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 2.0.0, 0.99.2
>            Reporter: Solomon Duskis
>            Assignee: Solomon Duskis
>             Fix For: 1.0.0
>         Attachments: HBASE-12611.patch
> There was quite a bit of good discussion on HBASE-12490 about this topic.  [~stack] and
[~ndimiduk] came to the conclusion that the flush method should be called autoCommit() similar
to the SQL APIs.   [~ndimiduk]  also suggested that clearBufferOnFail should be removed from

This message was sent by Atlassian JIRA

View raw message