hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop Sam John (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-12313) Redo the hfile index length optimization so cell-based rather than serialized KV key
Date Sun, 26 Oct 2014 09:04:33 GMT

    [ https://issues.apache.org/jira/browse/HBASE-12313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14184438#comment-14184438
] 

Anoop Sam John commented on HBASE-12313:
----------------------------------------

{code}
       for (Cell cell : rr.rawCells()) {
-        resultSize += CellUtil.estimatedLengthOf(cell);
+        resultSize += CellUtil.estimatedSerializedSizeOf(cell);
{code}
estimatedLengthOf was returning the total length. estimatedSerializedSizeOf() is having extra
count 4 bytes +.   Do you want to change really Stack?

> Redo the hfile index length optimization so cell-based rather than serialized KV key
> ------------------------------------------------------------------------------------
>
>                 Key: HBASE-12313
>                 URL: https://issues.apache.org/jira/browse/HBASE-12313
>             Project: HBase
>          Issue Type: Sub-task
>          Components: regionserver, Scanners
>            Reporter: stack
>            Assignee: stack
>         Attachments: 0001-HBASE-12313-Redo-the-hfile-index-length-optimization.patch,
0001-HBASE-12313-Redo-the-hfile-index-length-optimization.patch, 0001-HBASE-12313-Redo-the-hfile-index-length-optimization.patch,
0001-HBASE-12313-Redo-the-hfile-index-length-optimization.patch, 0001-HBASE-12313-Redo-the-hfile-index-length-optimization.patch,
12313v5.txt
>
>
> Trying to remove API that returns the 'key' of a KV serialized into a byte array is thorny.
> I tried to move over the first and last key serializations and the hfile index entries
to be cell but patch was turning massive.  Here is a smaller patch that just redoes the optimization
that tries to find 'short' midpoints between last key of last block and first key of next
block so it is Cell-based rather than byte array based (presuming Keys serialized in a certain
way).  Adds unit tests which we didn't have before.
> Also remove CellKey.  Not needed... at least not yet.  Its just utility for toString.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message