hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elliott Clark (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-12245) Snapshots going corrupt after creation
Date Mon, 13 Oct 2014 20:45:35 GMT

    [ https://issues.apache.org/jira/browse/HBASE-12245?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14169924#comment-14169924
] 

Elliott Clark commented on HBASE-12245:
---------------------------------------

Sorry can't post everything. 
{code}
hbase org.apache.hadoop.hbase.snapshot.SnapshotInfo -stats -files -snapshot MailBox_cell16_v1_2014-10-10-125917
| grep NOT
       - TABLE/7f4112f68d74c6de31aae30a2373b714/M/a9a75914e357495a90e2e93c88d5db0e (NOT FOUND)
       - TABLE/c0423bdc4b87d3b33be3c91f2452dabd/K/cb557271f69442e89caf1982c0f61cd5 (NOT FOUND)
       - TABLE/d437461577613a475160ee579ea1e203/S/31c3d53620ad402cbf44232013834f7b (NOT FOUND)
       - TABLE/f3948c1d081a2740fb74976b8653e053/D/160f562d2a9a4c9388a305fd054c8ac1 (NOT FOUND)
{code}
All of the files are from different regions. All of them are from different stores. None of
the tables have recently had their schema changed.
None of those files are mentioned in the master logs.
I'm starting to search the region server logs now.

> Snapshots going corrupt after creation
> --------------------------------------
>
>                 Key: HBASE-12245
>                 URL: https://issues.apache.org/jira/browse/HBASE-12245
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.98.7
>            Reporter: Elliott Clark
>            Priority: Critical
>
> Took a snapshot Fri Oct 10 12:59:35 PDT 2014. Everything reported good and all files
were there.
> Ran an export snapshot job over the weekend.
> Came back this morning and all the jobs had failed and now the snapshot is corrupt.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message