hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-10870) Deprecate and replace HCD methods that have a 'should' prefix with a 'get' instead
Date Fri, 31 Oct 2014 17:24:35 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10870?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14192115#comment-14192115
] 

Hudson commented on HBASE-10870:
--------------------------------

SUCCESS: Integrated in HBase-TRUNK #5730 (See [https://builds.apache.org/job/HBase-TRUNK/5730/])
HBASE-10870 Deprecate and replace HCD methods that have a 'should' prefix with a 'is' instead
(stack: rev cacdb89e0345d4d507ae0ae04628d871d636fbca)
* hbase-client/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
* hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
* hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HStore.java


> Deprecate and replace HCD methods that have a 'should' prefix with a 'get' instead
> ----------------------------------------------------------------------------------
>
>                 Key: HBASE-10870
>                 URL: https://issues.apache.org/jira/browse/HBASE-10870
>             Project: HBase
>          Issue Type: Task
>    Affects Versions: 2.0.0
>            Reporter: stack
>            Assignee: Ashish Singhi
>             Fix For: 2.0.0, 0.99.2
>
>         Attachments: HBASE-10870.patch
>
>
> HColumnDescriptor has a bunch of methods that have 'should' for a prefix.  Deprecate
and give them a javabean 'get' or 'is' instead.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message