hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-12099) TestScannerModel fails if using jackson 1.9.13
Date Tue, 30 Sep 2014 18:54:36 GMT

     [ https://issues.apache.org/jira/browse/HBASE-12099?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Enis Soztutar updated HBASE-12099:
----------------------------------
      Resolution: Fixed
    Hadoop Flags: Incompatible change,Reviewed
          Status: Resolved  (was: Patch Available)

I've pushed this to 0.98+. Thanks Esteban and all. Esteban, would you mind adding a release
note here as well about the incompatibility in the XML format. 

> TestScannerModel fails if using jackson 1.9.13
> ----------------------------------------------
>
>                 Key: HBASE-12099
>                 URL: https://issues.apache.org/jira/browse/HBASE-12099
>             Project: HBase
>          Issue Type: Bug
>          Components: REST
>    Affects Versions: 2.0.0, 0.98.7, 0.99.1
>         Environment: hadoop-2.5.0
>            Reporter: Esteban Gutierrez
>            Assignee: Esteban Gutierrez
>             Fix For: 2.0.0, 0.98.7, 0.99.1
>
>         Attachments: 12099-1.txt, 12099-2.txt, HBASE-12099.v0.txt
>
>
> TestScannerModel fails if jackson 1.9.13 is used. (Hadoop 2.5 now uses that version,
see HADOOP-10104):
> {code}
> Failed tests:   testToJSON(org.apache.hadoop.hbase.rest.model.TestScannerModel): expected:<{"batch":100,"caching":1000,"cacheBlocks":false,"endRow":"enp5eng=","endTime":1245393318192,"maxVersions":2147483647,"startRow":"YWJyYWNhZGFicmE=","startTime":1245219839331,"column":["Y29sdW1uMQ==","Y29sdW1uMjpmb28="],"labels":["private","public"]}>
but was:<{"startRow":"YWJyYWNhZGFicmE=","endRow":"enp5eng=","batch":100,"startTime":1245219839331,"endTime":1245393318192,"maxVersions":2147483647,"caching":1000,"cacheBlocks":false,"column":["Y29sdW1uMQ==","Y29sdW1uMjpmb28="],"label":["private","public"]}>
> {code}
> The problem is the annotation used for the labels element which is 'label' instead of
'labels'.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message