hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jingcheng Du (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-12094) Clean the code after adding IS_MOB and MOB_THRESHOLD to column family
Date Thu, 25 Sep 2014 09:00:41 GMT

     [ https://issues.apache.org/jira/browse/HBASE-12094?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jingcheng Du updated HBASE-12094:
---------------------------------
    Attachment: HBASE-12094.diff

Upload the patch to clean the duplicated code and the code that reference them.

> Clean the code after adding IS_MOB and MOB_THRESHOLD to column family
> ---------------------------------------------------------------------
>
>                 Key: HBASE-12094
>                 URL: https://issues.apache.org/jira/browse/HBASE-12094
>             Project: HBase
>          Issue Type: Sub-task
>          Components: regionserver, Scanners
>            Reporter: Jingcheng Du
>            Assignee: Jingcheng Du
>             Fix For: hbase-11339
>
>         Attachments: HBASE-12094.diff
>
>
> Previously we defined two attribute IS_MOB and MOB_THRESHOLD in  the MobConstants, and
defined the method getMobThreshold() and isMobColumnFamily() in the MobUtils.
> Now we have these attributes and methods in HColumnDescriptor. They're duplicated, we
will remove the ones in MobConstants and MobUtils, and modify the code that reference them.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message