hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11877) Make TableSplit more readable
Date Fri, 05 Sep 2014 07:42:27 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11877?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14122557#comment-14122557
] 

Hudson commented on HBASE-11877:
--------------------------------

SUCCESS: Integrated in HBase-0.98-on-Hadoop-1.1 #471 (See [https://builds.apache.org/job/HBase-0.98-on-Hadoop-1.1/471/])
HBASE-11877 Make TableSplit more readable (Liu Shaohui) (stack: rev 817f30110e6fdcba468c848f4dc458ecf164ce1e)
* hbase-server/src/main/java/org/apache/hadoop/hbase/mapred/TableSplit.java
* hbase-server/src/test/java/org/apache/hadoop/hbase/mapreduce/TestTableSplit.java
* hbase-server/src/main/java/org/apache/hadoop/hbase/mapreduce/TableSplit.java
* hbase-server/src/test/java/org/apache/hadoop/hbase/mapred/TestSplitTable.java


> Make TableSplit more readable
> -----------------------------
>
>                 Key: HBASE-11877
>                 URL: https://issues.apache.org/jira/browse/HBASE-11877
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 2.0.0
>            Reporter: Liu Shaohui
>            Assignee: Liu Shaohui
>            Priority: Minor
>             Fix For: 0.99.0, 2.0.0, 0.98.7
>
>         Attachments: HBASE-11877-trunk-v1.diff, HBASE-11877-trunk-v2.diff
>
>
> When debugging MR jobs reading from hbase table, it's import to figure out which region
a map task is reading from.
> But the table split object is hard to read.
> eg:
> {code}
> 2014-09-01 20:58:39,783 INFO [main] org.apache.hadoop.mapred.MapTask: Processing split:
lg-hadoop-prc-st40.bj:,0
> {code}
> See: TableSplit.java 
> {code}
>   @Override
>   public String toString() {
>     return m_regionLocation + ":" +
>       Bytes.toStringBinary(m_startRow) + "," + Bytes.toStringBinary(m_endRow);
>   }
> {code}
> We should make it more readable.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message