hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11761) Add a FAQ item for updating a maven-managed application from 0.94 -> 0.96+
Date Wed, 10 Sep 2014 15:40:34 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11761?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14128613#comment-14128613
] 

Sean Busbey commented on HBASE-11761:
-------------------------------------

Could you reorder the examples so they're in increasing version #s? My thinking is that for
people reading this entry because they need to upgrade, that will make things move from what
they're familiar with to what they need to do.

Is it worth including a pointer from the upgrade sections on 0.96 and 0.98 to this new FAQ
entry?

> Add a FAQ item for updating a maven-managed application from 0.94 -> 0.96+
> --------------------------------------------------------------------------
>
>                 Key: HBASE-11761
>                 URL: https://issues.apache.org/jira/browse/HBASE-11761
>             Project: HBase
>          Issue Type: Task
>          Components: documentation
>            Reporter: Sean Busbey
>            Assignee: Misty Stanley-Jones
>              Labels: beginner
>         Attachments: HBASE-11761.patch
>
>
> In 0.96 we changed artifact structure, so that clients need to rely on an artifact specific
to some module (hopefully hbase-client) instead of a single fat jar.
> We should add a FAQ item that points people towards hbase-client, to ease those updating
downstream applications from 0.94 to 0.98+.
> Showing an example pom entry for e.g. org.apache.hbase:hbase:0.94.22 and one for e.g.
org.apache.hbase:hbase-client:0.98.5 should be sufficient.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message