hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jingcheng Du (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-11643) Read and write MOB in HBase
Date Wed, 17 Sep 2014 02:17:35 GMT

     [ https://issues.apache.org/jira/browse/HBASE-11643?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jingcheng Du updated HBASE-11643:
---------------------------------
    Attachment: HBASE-11643-addendum.diff

Upload the patch HBASE-11643-addendum.diff to rename the attr in values of column family.
Previously the attr in the values of column descriptor are isMob and mobThreshold which break
the naming convention.
In this patch they're changed to IS_MOB and MOB_THRESHOLD.

> Read and write MOB in HBase
> ---------------------------
>
>                 Key: HBASE-11643
>                 URL: https://issues.apache.org/jira/browse/HBASE-11643
>             Project: HBase
>          Issue Type: Sub-task
>          Components: regionserver, Scanners
>            Reporter: Jingcheng Du
>            Assignee: Jingcheng Du
>             Fix For: hbase-11339
>
>         Attachments: HBASE-11643-V10.diff, HBASE-11643-V11.diff, HBASE-11643-V12.diff,
HBASE-11643-V13.diff, HBASE-11643-V14.diff, HBASE-11643-V15.diff, HBASE-11643-V16.diff, HBASE-11643-V17.diff,
HBASE-11643-V18.diff, HBASE-11643-V19.diff, HBASE-11643-V2.diff, HBASE-11643-V20.diff, HBASE-11643-V3.diff,
HBASE-11643-V4.diff, HBASE-11643-V5.diff, HBASE-11643-V6.diff, HBASE-11643-V7.diff, HBASE-11643-V8.diff,
HBASE-11643-V9.diff, HBASE-11643-addendum.diff, HBase-11643.diff
>
>
> The read/write MOB in HBase are implemented in this JIRA. Normally, the Cells are saved
in the MemStore, and flushed to the HFiles when necessary. For MOB, the Cells are saved in
the MemStore as well, but they're flushed to elsewhere out of HBase in the format of HFiles.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message