hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Dimiduk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11153) http webUI's should redirect to https when enabled
Date Tue, 30 Sep 2014 22:39:34 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11153?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14153908#comment-14153908
] 

Nick Dimiduk commented on HBASE-11153:
--------------------------------------

Thanks for investigating [~kiranmr]. I guess we'll close this as 'Won't Fix' unless you'd
like to have a go at #3 above? We'll need to choose an HTTPS port that doesn't conflict with
other stuff (multi-RS/host comes to mind).

Ping [~stack] and [~jxiang] as they've both looked at port auto-assignment in the past.

> http webUI's should redirect to https when enabled
> --------------------------------------------------
>
>                 Key: HBASE-11153
>                 URL: https://issues.apache.org/jira/browse/HBASE-11153
>             Project: HBase
>          Issue Type: Bug
>          Components: master, regionserver, UI
>    Affects Versions: 0.98.0
>            Reporter: Nick Dimiduk
>            Assignee: Kiran Kumar M R
>            Priority: Minor
>              Labels: beginner
>
> When configured to listen on https, we should redirect non-secure requests to the appropriate
port/protocol. Currently we respond with a 200 and no data, which is perplexing.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message