hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HBASE-10200) Better error message when HttpServer fails to start due to java.net.BindException
Date Mon, 29 Sep 2014 23:05:34 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14152476#comment-14152476
] 

Ted Yu edited comment on HBASE-10200 at 9/29/14 11:04 PM:
----------------------------------------------------------

Looks like QA bot consistently encounters the following:
{code}
Caused by: hudson.plugins.git.GitException: Failed to connect to https://git-wip-us.apache.org/repos/asf/hbase.git
(exception: java.net.UnknownHostException: git-wip-us.apache.org: Name or service not known)
	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.checkCredentials(CliGitAPIImpl.java:1960)
	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1137)
{code}
Running test suite locally now.


was (Author: yuzhihong@gmail.com):
Looks like QA bot consistently encounters the following:
{code}
Caused by: hudson.plugins.git.GitException: Failed to connect to https://git-wip-us.apache.org/repos/asf/hbase.git
(exception: java.net.UnknownHostException: git-wip-us.apache.org: Name or service not known)
	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.checkCredentials(CliGitAPIImpl.java:1960)
	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1137)
{code}
Running test suite now.

> Better error message when HttpServer fails to start due to java.net.BindException
> ---------------------------------------------------------------------------------
>
>                 Key: HBASE-10200
>                 URL: https://issues.apache.org/jira/browse/HBASE-10200
>             Project: HBase
>          Issue Type: Task
>    Affects Versions: 2.0.0
>            Reporter: Ted Yu
>            Priority: Minor
>              Labels: beginner
>         Attachments: HBASE-10020.patch
>
>
> Starting HBase using Hoya, I saw the following in log:
> {code}
> 2013-12-17 21:49:06,758 INFO  [master:hor12n19:42587] http.HttpServer: HttpServer.start()
threw a non Bind IOException
> java.net.BindException: Port in use: hor12n14.gq1.ygridcore.net:12432
>         at org.apache.hadoop.http.HttpServer.openListener(HttpServer.java:742)
>         at org.apache.hadoop.http.HttpServer.start(HttpServer.java:686)
>         at org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:586)
>         at java.lang.Thread.run(Thread.java:722)
> Caused by: java.net.BindException: Cannot assign requested address
>         at sun.nio.ch.Net.bind0(Native Method)
>         at sun.nio.ch.Net.bind(Net.java:344)
>         at sun.nio.ch.Net.bind(Net.java:336)
>         at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:199)
>         at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
>         at org.mortbay.jetty.nio.SelectChannelConnector.open(SelectChannelConnector.java:216)
>         at org.apache.hadoop.http.HttpServer.openListener(HttpServer.java:738)
> {code}
> This was due to hbase.master.info.bindAddress giving static address but Hoya allocates
master dynamically.
> Better error message should be provided: when bindAddress points another host than local
host, message should remind user to remove / adjust hbase.master.info.bindAddress config param
from hbase-site.xml



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message