hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11828) callers of SeverName.valueOf should use equals and not ==
Date Tue, 26 Aug 2014 17:25:58 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11828?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14110980#comment-14110980

stack commented on HBASE-11828:

For history on this (provided by Sean offline), HBASE-10012 added valueOf but not the internal
caching implementation.

> callers of SeverName.valueOf should use equals and not ==
> ---------------------------------------------------------
>                 Key: HBASE-11828
>                 URL: https://issues.apache.org/jira/browse/HBASE-11828
>             Project: HBase
>          Issue Type: Improvement
>          Components: Client
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>            Priority: Minor
>              Labels: documentation
>         Attachments: HBASE-11828.patch
> ServerName.valueOf is missing docs about the safety of using == vs .equals on returned
> For clarity, we should specify that users are expected to use .equals even though we
may return shared immutable instances. The .equals method short circuits on object equality,
so the cost difference in the positive case is 1 function call.
> Current behavior is to return a new instance on each call (0.96, 0.98, branch-1, master).
So presumably any current users are either doing this or they have a bug.

This message was sent by Atlassian JIRA

View raw message