hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jimmy Xiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11531) RegionStates for regions under region-in-transition znode are not updated on startup
Date Thu, 17 Jul 2014 17:31:06 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11531?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14065175#comment-14065175
] 

Jimmy Xiang commented on HBASE-11531:
-------------------------------------

I see the problem now: you restarted the master during the first phase of the migration, while
some region is opening. The meta is already updated and the OPENED znode hasn't been processed
when the master died. It might be better to restart the master at the end during the first
phase. For code-wise, we may be able to do something to improve the migration experience.

> RegionStates for regions under region-in-transition znode are not updated on startup
> ------------------------------------------------------------------------------------
>
>                 Key: HBASE-11531
>                 URL: https://issues.apache.org/jira/browse/HBASE-11531
>             Project: HBase
>          Issue Type: Bug
>          Components: Region Assignment
>    Affects Versions: 0.99.0
>            Reporter: Virag Kothari
>         Attachments: sample.patch
>
>
> While testing HBASE-11059, saw that if there are regions under region-in-transition znode
their states are not updated in META and master memory on startup.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message