hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11493) Autorestart option is not working because of stale znode "shutdown"
Date Mon, 14 Jul 2014 09:31:06 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11493?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14060471#comment-14060471
] 

Hudson commented on HBASE-11493:
--------------------------------

SUCCESS: Integrated in HBase-TRUNK #5297 (See [https://builds.apache.org/job/HBase-TRUNK/5297/])
HBASE-11493 Autorestart option is not working because of stale znode 'shutdown'(Nijel) (rajeshbabu:
rev 5a05836dd13deac020443a0d3e84cb7bcfde7552)
* bin/hbase-daemon.sh


> Autorestart option is not working because of stale znode  "shutdown"
> --------------------------------------------------------------------
>
>                 Key: HBASE-11493
>                 URL: https://issues.apache.org/jira/browse/HBASE-11493
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.98.3
>            Reporter: Nishan Shetty
>            Assignee: nijel
>             Fix For: 0.99.0, 0.98.4, 2.0.0
>
>         Attachments: HBASE-11493.patch, HBASE-11493.v1.patch
>
>
> In hbase-daemon.sh autorestart option the znode used is "shutdown"
> {code}
> zshutdown=`$bin/hbase org.apache.hadoop.hbase.util.HBaseConfTool zookeeper.znode.state`
>         if [ "$zshutdown" == "null" ]; then zshutdown="shutdown"; fi
>         zFullShutdown=$zparent/$zshutdown
> {code}
> the node shutdown is not available now and is changed to running.
> *Since this node is not available, script does not restart the node and it exists.*
> So autorestart scripts needs to be changed to  make use of "running" znode.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message