hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nijel (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-11493) Autorestart option is not working because of stale znode "shutdown"
Date Thu, 10 Jul 2014 15:52:04 GMT

     [ https://issues.apache.org/jira/browse/HBASE-11493?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

nijel updated HBASE-11493:
--------------------------

    Attachment: HBASE-11493.v1.patch

Updated patch from git

> Autorestart option is not working because of stale znode  "shutdown"
> --------------------------------------------------------------------
>
>                 Key: HBASE-11493
>                 URL: https://issues.apache.org/jira/browse/HBASE-11493
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.98.3
>            Reporter: Nishan Shetty
>         Attachments: HBASE-11493.patch, HBASE-11493.v1.patch
>
>
> In hbase-daemon.sh autorestart option the znode used is "shutdown"
> {code}
> zshutdown=`$bin/hbase org.apache.hadoop.hbase.util.HBaseConfTool zookeeper.znode.state`
>         if [ "$zshutdown" == "null" ]; then zshutdown="shutdown"; fi
>         zFullShutdown=$zparent/$zshutdown
> {code}
> the node shutdown is not available now and is changed to running.
> *Since this node is not available, script does not restart the node and it exists.*
> So autorestart scripts needs to be changed to  make use of "running" znode.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message