hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Drob (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-7910) Dont use reflection for security
Date Fri, 18 Jul 2014 23:46:40 GMT

     [ https://issues.apache.org/jira/browse/HBASE-7910?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mike Drob updated HBASE-7910:
-----------------------------

    Attachment: HBASE-7910.patch.txt

I wasn't able to remove the reflective calls for {{org.apache.hadoop.hbase.security.token.TokenUtil}},
but I'm not sure if that was in scope for this JIRA.

> Dont use reflection for security
> --------------------------------
>
>                 Key: HBASE-7910
>                 URL: https://issues.apache.org/jira/browse/HBASE-7910
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Enis Soztutar
>            Assignee: Mike Drob
>              Labels: noob
>         Attachments: HBASE-7910.patch.txt
>
>
> security.User class uses reflection so that HBase can work with older Hadoop's not having
security. Now that we require 1.x, or 0.23 or 2.x, all Hadoop versions have security code.
We can get rid of most of the User class. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message