hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-3197) Using the same HBaseConfiguration for multiple puts makes some data not to be written
Date Wed, 16 Jul 2014 23:17:05 GMT

     [ https://issues.apache.org/jira/browse/HBASE-3197?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Purtell resolved HBASE-3197.
-----------------------------------

    Resolution: Cannot Reproduce

Reopen or file new issue is still relevant with modern HBase versions

> Using the same HBaseConfiguration for multiple puts makes some data not to be written
> -------------------------------------------------------------------------------------
>
>                 Key: HBASE-3197
>                 URL: https://issues.apache.org/jira/browse/HBASE-3197
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.20.6
>         Environment: HBase cluster running on 6 machines (Centos 5.5, Intel Dual Core/core
i3, ram 4/8GB)
>            Reporter: Francesco Angi
>
> I created a DAO object for loading and storing data into HBase. The DAO has a HBaseConfiguration
field, created inside the DAO constructor. Each DAO's method creates a new HTable using the
class's HBaseConfiguration. The problem shows up when subsequent writings (using a put) are
invoked, since not all the data is written. Moreover this behaviour is not deterministic:
invoking the same writings never writes all the data, but the missing ones change every time.
> I solved this situation removing the class's HBaseConfiguration and creating a new HBaseConfiguration
inside each method.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message