hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Boudnik (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-11418) biuld targe {{site}} doesn't respect hadoop-two.version property
Date Fri, 27 Jun 2014 01:41:24 GMT
Konstantin Boudnik created HBASE-11418:
------------------------------------------

             Summary: biuld targe {{site}} doesn't respect hadoop-two.version property
                 Key: HBASE-11418
                 URL: https://issues.apache.org/jira/browse/HBASE-11418
             Project: HBase
          Issue Type: Bug
          Components: build
    Affects Versions: 0.98.3
            Reporter: Konstantin Boudnik
            Assignee: Konstantin Boudnik
             Fix For: 0.98.4


Running build with {{mvn clean site -Dhadoop-two.version=2.3.0}} I see that it pulls in Hadoop
2.2.0 dependencies (when building 0.98.x); and Hadoop 2.3.0 on the master. The reason of the
behavior is the bug in configuration of {{userapi}} reportset, namely:
{code}
              <docletArtifact>
                <groupId>org.apache.hadoop</groupId>
                <!-- doclet lives in hadoop 2's hadoop-common module -->
                <artifactId>hadoop-common</artifactId>
                <version>2.3.0</version>
              </docletArtifact>
{code}
(the snipped is from the master branch)



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message