hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicolas Liochon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11298) Simplification in RpcServer code
Date Fri, 06 Jun 2014 13:30:02 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11298?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14019841#comment-14019841

Nicolas Liochon commented on HBASE-11298:

bq. Why we no longer need this: - if (inHandler) {
It's always called with inHandler set to false. This code is as well refactored in HBASE-11297

bq. Oh, you made the RPC trace-level? Thats better (include doc change in your patch?)
Yeah, I've done the cleanup (hopefully).
I don't see a mention of "org.apache.hadoop.ipc.RpcServer" in the HBase book? May be somewhere

bq. On other hand this new method sets the buffer and authmethod... so maybe just leave as
is and doc it sets these two data members on success.
Yeah agreed.

> Simplification in RpcServer code
> --------------------------------
>                 Key: HBASE-11298
>                 URL: https://issues.apache.org/jira/browse/HBASE-11298
>             Project: HBase
>          Issue Type: Bug
>          Components: regionserver
>    Affects Versions: 0.99.0
>            Reporter: Nicolas Liochon
>            Assignee: Nicolas Liochon
>             Fix For: 0.99.0
>         Attachments: 11298.v1.patch
> No important changes here, but I'm doing some other changes on top of this (typically
> Note that I've changed the logs, they now belong to the "real" class instead of hijacking
Hadoop. I suppose it was historical, but it was as well very confusing.

This message was sent by Atlassian JIRA

View raw message