hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-11298) Simplification in RpcServer code
Date Wed, 04 Jun 2014 17:21:02 GMT

    [ https://issues.apache.org/jira/browse/HBASE-11298?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14017890#comment-14017890

stack commented on HBASE-11298:

bq. Note that I've changed the logs, they now belong to the "real" class instead of hijacking

RPC DEBUG is verbose, more verbose than all other hbase DEBUG logging so much so that it overwhelms.
 Above is an old means of enabling RPC DEBUG independent of DEBUG level everywhere else in
HBASE.  We'd doc'd it here: http://hbase.apache.org/book.html#rpc.logging

Maybe not INFO level is default and RPC logging has had an edit, it might be OK making it
so DEBUG enable'd RPC logging..... have you checked?

Oh, you made the RPC trace-level?  Thats better (include doc change in your patch?)

Why we no longer need this: -            if (inHandler) {

Should you pass in the buffer readPreamble works on rather than rely on 'this'?  I don't like
methods that have side effects; i.e. setting 'this' items if it returns successufully. On
other hand this new method sets the buffer and authmethod... so maybe just leave as is and
doc it sets these two data members on success.

Otherwise, cleanup looks good to me.  +1 to commit if hadoopqa doesn't burp.

> Simplification in RpcServer code
> --------------------------------
>                 Key: HBASE-11298
>                 URL: https://issues.apache.org/jira/browse/HBASE-11298
>             Project: HBase
>          Issue Type: Bug
>          Components: regionserver
>    Affects Versions: 0.99.0
>            Reporter: Nicolas Liochon
>            Assignee: Nicolas Liochon
>             Fix For: 0.99.0
>         Attachments: 11298.v1.patch
> No important changes here, but I'm doing some other changes on top of this (typically
> Note that I've changed the logs, they now belong to the "real" class instead of hijacking
Hadoop. I suppose it was historical, but it was as well very confusing.

This message was sent by Atlassian JIRA

View raw message