hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Misty Stanley-Jones (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-11102) Document JDK versions supported by each release
Date Sun, 22 Jun 2014 23:31:25 GMT

     [ https://issues.apache.org/jira/browse/HBASE-11102?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Misty Stanley-Jones updated HBASE-11102:
----------------------------------------

    Status: Patch Available  (was: Open)

Please review for accuracy. I wanted to go back to 0.90 because we talk about it elsewhere,
and I couldn't find any reference to JDK 7 being supported prior to 0.92.

> Document JDK versions supported by each release
> -----------------------------------------------
>
>                 Key: HBASE-11102
>                 URL: https://issues.apache.org/jira/browse/HBASE-11102
>             Project: HBase
>          Issue Type: Sub-task
>          Components: documentation
>            Reporter: Enis Soztutar
>            Assignee: Misty Stanley-Jones
>             Fix For: 0.99.0
>
>         Attachments: HBASE-11102.patch
>
>
> We can make use of a JDK version x HBase version matrix to explain which JDK version
is supported and required. 
> 0.94, 0.96, and 0.98 releases all support JDK6 and JDK7. For 1.0, there is a discussion
thread to decide whether to drop JDK6 support. 
> There has been some work to support JDK8. We can also document that. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message