hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Dimiduk (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-11137) Add mapred.TableSnapshotInputFormat
Date Wed, 14 May 2014 20:06:20 GMT

     [ https://issues.apache.org/jira/browse/HBASE-11137?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nick Dimiduk updated HBASE-11137:
---------------------------------

    Attachment: HBASE-11137.00-0.98.patch

Here's a patch for 0.98, based on the trunk v01. I repeated the refactor manually, no fancy
git-rebase, so please give it the same scrutiny you'll give the trunk patch. Both have been
verified using IntegrationTestTableSnapshotInputFormat running on my local sandbox with numRegions=15
(this is a magic number that works with and without HBASE-9445, according to [~enis]).

> Add mapred.TableSnapshotInputFormat
> -----------------------------------
>
>                 Key: HBASE-11137
>                 URL: https://issues.apache.org/jira/browse/HBASE-11137
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce, Performance
>    Affects Versions: 0.98.0, 0.96.2
>            Reporter: Nick Dimiduk
>            Assignee: Nick Dimiduk
>         Attachments: HBASE-11137.00-0.98.patch, HBASE-11137.00.patch, HBASE-11137.01.patch,
HBASE-11137.01_rerun.patch
>
>
> We should have feature parity between mapreduce and mapred implementations. This is important
for Hive.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message