hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-10903) HBASE-10740 regression; cannot pass commands for zk to run
Date Thu, 03 Apr 2014 22:17:39 GMT

     [ https://issues.apache.org/jira/browse/HBASE-10903?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack updated HBASE-10903:
--------------------------

       Resolution: Fixed
    Fix Version/s: 0.96.3
                   0.98.2
                   0.99.0
     Hadoop Flags: Reviewed
           Status: Resolved  (was: Patch Available)

Committed to 0.96-0.99 (Committed to 0.96 in case someone runs it against zk-3.4.6 -- verified
it works there too against zk-3.4.5).

Fix upstream is ZOOKEEPER-1897

> HBASE-10740 regression; cannot pass commands for zk to run
> ----------------------------------------------------------
>
>                 Key: HBASE-10903
>                 URL: https://issues.apache.org/jira/browse/HBASE-10903
>             Project: HBase
>          Issue Type: Bug
>          Components: Zookeeper
>    Affects Versions: 0.98.1, 0.99.0
>            Reporter: stack
>            Assignee: stack
>             Fix For: 0.99.0, 0.98.2, 0.96.3
>
>         Attachments: 10903.txt, 10903v2.txt
>
>
> We can't do this:
> {code}
> ./bin/hbase zkcli deleteall /hbase/rs/c2022.halxg.cloudera.com,16020,1396502726715
> {code}
> after upgrade to 3.4.6 zookeeper.  Works if I put back 3.4.5.
> See below where only difference is the zk jar:
> {code}
> [stack@c2022 hbase-0.99.0-SNAPSHOT]$ ~/bin/java/bin/java -cp ~/hbase-0.96.1.1-hadoop2/lib/zookeeper-3.4.5.jar:lib/slf4j-log4j12-1.6.4.jar:lib/slf4j-api-1.6.4.jar:lib/log4j-1.2.17.jar
 org.apache.zookeeper.ZooKeeperMain -server c2020:2181 ls  "/hbase/rs"
> Connecting to c2020:2181
> log4j:WARN No appenders could be found for logger (org.apache.zookeeper.ZooKeeper).
> log4j:WARN Please initialize the log4j system properly.
> log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
> WATCHER::
> WatchedEvent state:SyncConnected type:None path:null
> [c2020.halxg.cloudera.com,16020,1396482186194, c2021.halxg.cloudera.com,16020,1396499398203,
c2023.halxg.cloudera.com,16020,1396498834473, c2025.halxg.cloudera.com,16020,1396482188110,
c2022.halxg.cloudera.com,16020,1396502726715, c2024.halxg.cloudera.com,16020,1396482188280]
> [stack@c2022 hbase-0.99.0-SNAPSHOT]$ ~/bin/java/bin/java -cp lib/zookeeper-3.4.6.jar:lib/slf4j-log4j12-1.6.4.jar:lib/slf4j-api-1.6.4.jar:lib/log4j-1.2.17.jar
 org.apache.zookeeper.ZooKeeperMain -server c2020:2181 ls  "/hbase/rs"
> Connecting to c2020:2181
> log4j:WARN No appenders could be found for logger (org.apache.zookeeper.ZooKeeper).
> log4j:WARN Please initialize the log4j system properly.
> log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message