hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-10690) Drop Hadoop-1 support
Date Sat, 08 Mar 2014 00:52:47 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10690?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13924588#comment-13924588
] 

Enis Soztutar commented on HBASE-10690:
---------------------------------------

Agreed that there should be only one artifact. We can remove generate-poms script. We can
keep the profiles for now just in case. If we will do a different profile for 2.3, we will
need hadoop.profile anyway. 

> Drop Hadoop-1 support
> ---------------------
>
>                 Key: HBASE-10690
>                 URL: https://issues.apache.org/jira/browse/HBASE-10690
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Enis Soztutar
>            Priority: Critical
>             Fix For: 0.99.0
>
>
> As per thread:
> http://mail-archives.apache.org/mod_mbox/hbase-dev/201403.mbox/%3CCAMUu0w93MGp7ZBbxGccOV+be3EtMkvn5ATZOwvzQD_gegdK4NQ@mail.gmail.com%3E
> It seems that the consensus is that supporting Hadoop-1 in HBase-1.x will be costly,
so we should drop the support. 
> In this issue: 
>  - We'll document that Hadoop-1 support is deprecated in HBase-0.98. And users should
switch to hadoop-2.2+ anyway. 
>  - Document that upcoming HBase-0.99 and HBase-1.0 releases will not have Hadoop-1 support.

>  - Document that there is no rolling upgrade support for going between Hadoop-1 and Hadoop-2
(using HBase-0.96 or 0.98).
>  - Release artifacts won't contain HBase build with Hadoop-1. 
>  - We may keep the profile, jenkins job etc if we want.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message