hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ramkrishna.s.vasudevan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-10531) Revisit how the key byte[] is passed to HFileScanner.seekTo and reseekTo
Date Wed, 05 Mar 2014 11:48:45 GMT

     [ https://issues.apache.org/jira/browse/HBASE-10531?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

ramkrishna.s.vasudevan updated HBASE-10531:
-------------------------------------------

    Attachment: HBASE-10532_2.patch

I have uploaded a patch that uses an inner class KeyAloneKeyValue that does not copy the bytes.
I have not yet removed the duplicate code.  Let me know what you think on this. 

> Revisit how the key byte[] is passed to HFileScanner.seekTo and reseekTo
> ------------------------------------------------------------------------
>
>                 Key: HBASE-10531
>                 URL: https://issues.apache.org/jira/browse/HBASE-10531
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: ramkrishna.s.vasudevan
>            Assignee: ramkrishna.s.vasudevan
>             Fix For: 0.99.0
>
>         Attachments: HBASE-10531.patch, HBASE-10531_1.patch, HBASE-10531_2.patch
>
>
> Currently the byte[] key passed to HFileScanner.seekTo and HFileScanner.reseekTo, is
a combination of row, cf, qual, type and ts.  And the caller forms this by using kv.getBuffer,
which is actually deprecated.  So see how this can be achieved considering kv.getBuffer is
removed.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message