hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeffrey Zhong (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-10582) 0.94->0.96 Upgrade: ACL can't be repopulated when ACL table contains row for table '-ROOT' or '.META.'
Date Fri, 21 Feb 2014 02:32:21 GMT

     [ https://issues.apache.org/jira/browse/HBASE-10582?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jeffrey Zhong updated HBASE-10582:
----------------------------------

    Status: Patch Available  (was: Open)

> 0.94->0.96 Upgrade: ACL can't be repopulated when ACL table contains row for table
'-ROOT' or '.META.'
> ------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-10582
>                 URL: https://issues.apache.org/jira/browse/HBASE-10582
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.96.1, 0.96.0, 0.98.0
>            Reporter: Jeffrey Zhong
>            Assignee: Jeffrey Zhong
>            Priority: Critical
>         Attachments: hbase-10582.patch
>
>
> When '-ROOT-', '.META' rows are contained in ACL table, during upgrade process, ACL zk
nodes can't be populated to zookeeper because AccessControlLists#loadAll(HRegion) fails to
load table permissions due to 
> parsePermissionRecord throws IllegalArgumentException from TableName.valueof.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message