hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Dimiduk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-10526) Using Cell instead of KeyValue in HFileOutputFormat
Date Wed, 19 Feb 2014 21:40:29 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10526?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13906131#comment-13906131

Nick Dimiduk commented on HBASE-10526:

bq. append a # seems reasonable to me – given your argument should we rename metrics2 and
hfilev2 as well?

I can't speak to metrics as I don't know well enough what changed from the first implementation
to the second. Not so on the HFile because that's a different serialization format. Having
versioning there is acceptable, I think, though were it a public API I would argue for managing
API changes as we do with other public APIs. Even that is done relatively well, given the
presence of AbstractHFileReader, etc.

In this case, we're talking about a public API which itself has not changed (a blanket copy-paste,
right?), only the detail of which class is instantiated in the template. That's not a serialization
format change and it's not a significant API change (though it is one). As I said, there's
no way for us to work around this in Java, so I guess that's that.

> Using Cell instead of KeyValue in HFileOutputFormat
> ---------------------------------------------------
>                 Key: HBASE-10526
>                 URL: https://issues.apache.org/jira/browse/HBASE-10526
>             Project: HBase
>          Issue Type: Sub-task
>          Components: mapreduce
>            Reporter: Jimmy Xiang
>            Assignee: Jimmy Xiang
>         Attachments: hbase-10526.patch, hbase-10526_v1.1.patch, hbase-10526_v2.patch,
> HFileOutputFormat/KeyValueSortReducer use KeyValue. We should deprecate them and use
Cell instead.

This message was sent by Atlassian JIRA

View raw message