hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hsieh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-10526) Using Cell instead of KeyValue in HFileOutputFormat
Date Wed, 19 Feb 2014 17:46:27 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10526?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13905751#comment-13905751
] 

Jonathan Hsieh commented on HBASE-10526:
----------------------------------------

Nick D
bq. I'm not a fan of maintaining both versions of this thing – and especially not a fan
of the new class's name because it confuses the file format version.
bq. Can we instead deprecate the KeyValue version in 0.96, 0.98 and replace it with the Cell
version on trunk?

jimmy
bq. It's better not to simply replace it, which may impact the upgrade path of some existing
old applications. As to the class name, I am open for suggestions.

v2 has HFIleOutputFormat (KV version) deprecated and pointing to HFileOutputFormat2 (Cell
version).   I'd be fine if 0.98 and 0.96 had both with the old KV version deprecated. (I'd
argue this is early enough in both branch's lives and this is a compat problem from 0.94.)
  I'd also prefer it if trunk could remove the old version and only have the Cell version.

I think HFileOutputFormat2 is as good as any.  We are still writing the same files out --
just providing a api cleanup.

 

> Using Cell instead of KeyValue in HFileOutputFormat
> ---------------------------------------------------
>
>                 Key: HBASE-10526
>                 URL: https://issues.apache.org/jira/browse/HBASE-10526
>             Project: HBase
>          Issue Type: Sub-task
>          Components: mapreduce
>            Reporter: Jimmy Xiang
>            Assignee: Jimmy Xiang
>         Attachments: hbase-10526.patch, hbase-10526_v1.1.patch, hbase-10526_v2.patch
>
>
> HFileOutputFormat/KeyValueSortReducer use KeyValue. We should deprecate them and use
Cell instead.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message